프로젝트

일반

사용자정보

ECLIPSE  연동

Redmine용 Mylyn설치

1) Eclipse에서 Help -> Install New Software를 클릭합니다.

이전에는 Work with란에 아래의 URL을 입력하여 설치가 되었으나 현재는 여러가지 에러가 발생하고 있어 업데이트가 될 때까지는 파일로 설치하는 방법을 사용해야 합니다.

향후 업그레이드가 되면 설치가 가능할 수도 있으니 남겨 놓습니다.
(URL : http://redmin-mylyncon.sourceforge.net/update-site/N/)

2) 파일로 설치하는 방법은 현재일(2018. 6. 11) 기준으로 아래의 사이트에서 다운로드한 파일로 설치가 가능합니다.

https://github.com/ljader/redmine-mylyn-plugin/releases/download/release-0.5.1.201710222219/net.sf.redmine_mylyn.p2repository-0.5.1.201710222219.zip

3) Add버튼을 클릭하면 아래와 같이 팝업이 뜹니다. Archive...버튼을 클릭해서 위에서 다운로드한 파일을 찾아서 선택해 줍니다.

*나머지 과정은 일반적일 이클립스 설치과정이므로 생략합니다. 설치가 완료되면 이클립스가 재기동 됩니다.

 

Redmine과 Mylyn 연동하기

Task Repository 추가하기

Redmine과 Mylyn을 연동하기 위해서는 먼저 Task Repositories View에 Redmine Server를 추가해야 합니다.
Eclipse에서 Window -> Show View -> Other를 클릭합니다.

Mylyn의 Task Repositories를 클릭하고 OK를 누릅니다.

 

Task Repositories View가 Eclipse 하단에 표시되면 오른쪽의 Add Task Repository Button을 클릭합니다.

 

Add Task Repository Dialog에서 Redmine을 선택한 다음 Next를 누릅니다.

 

Redmine Repository Settings Dialog가 표시되면 다음과 같은 항목을 입력합니다.
Server: Redmine 접속 URL을 입력합니다.
Label: Task Repositories View에 표시될 이름을 입력합니다.
User ID: Redmine 사용자 ID를 입력합니다.
Password: Redmine 사용자 Password를 입력합니다.

입력 후에는 아래의 Vailidate Settings를 클릭하여 설정을 Check합니다. 제대로 인증되었다면 Finish를 누르면 됩니다.

 

작업 Repository를 등록 후 아래와 같이 query를 추가 여부 팝업 창이 표시되면 Yes 버튼을 클릭하여 진행합니다.

 

Query 추가하기

Task Repository가 추가되면 이제 Eclipse에서 Redmine의 Task를 관리할 준비가 된 것입니다. 이제 Query를 추가하여 개발자가 원하는 Task를 검색하여 관리해 봅시다.
처음 query를 작성한다면 Create a new query가 선택되어 있는 상태에서 Next 버튼을 클릭합니다. 

 

Query Title과 검색 조건을 입력 후 Finish 버튼을 클릭합니다.

 

Task List에 리스트가 표시되는 것을 확인합니다. 
(검색 조건에 해당하는 일감이 없다면 리스트에 아무것도 표시가 되지 않습니다)

 

리스트에서 일감을 클릭하면 일감 내용이 표시합니다.
(일감의 항목을 변경후 Submit을 클릭하면 변경된 내용이 반영됩니다.)

 

일감과 연동하여 커밋하기

우선 커밋 할 때의 메시지를 변경하기 위하여 Project -> Properties를 클릭합니다.

 

Task Repository -> Commit Template를 클릭하고 Commit Comment Template에 커밋할 때 사용할 기본 내용을 입력합니다. (해결 #${task.key}: ${task.description})

 

먼저 Task List에서 작업할 일감명 앞의 블릿을 체크합니다.

 

소스를 수정 후 커밋을 할 때 자동으로 앞에서 설정한 기본 커밋 메시지가 입력됩니다.

 

커밋이 완료되면 레드마인에서 해당 일감과 Eclipse에서 커밋한 리비전을 추적할 수 있도록 관련된 개정판들에 리비전이 등록됩니다. (개정판 번호를 클릭하면 변경 내용을 확인할 수 있습니다)

 

클립보드 이미지 추가 (최대 크기: 5 MB)